packagers

warning: Creating default object from empty value in /var/www/quassel-irc.org/htdocs/modules/taxonomy/taxonomy.pages.inc on line 33.

The Lucky (minor) Number -- Releasing Quassel IRC v0.7.1

It's that time of the year when we're releasing a new Quassel, and this time we strongly recommend updating your core or monolithic client at least, as in older versions there was an issue with CTCP handling that might allow bad and ugly people to make your core unresponsive. This issue is also the reason for the 0.7.0 release being officially skipped. People still on 0.6.x and not wanting to update to a new feature release should upgrade to version 0.6.3 in which this issue is fixed as well.

Now read on for a short list of the major new features the 0.7 flavour gives you, besides a ton of bugfixes and translation improvements!

Requiring Qt 4.6

In a few days, the master branch (which will become quassel-0.7) will start depending on Qt 4.6 for the client only. Besides giving us some very welcome API additions, and fixing a few bugs we currently have to work around, this also allows us to use Qt Kinetic and the Animation Framework in the future.

Qt 4.6 has been released about half a year ago, and is also required by the current stable KDE release, so we think that most desktop distros should be up to par by now (or don't care enough about staying up-to-date, in which case they shouldn't be expected to ship a bleeding edge Quassel anyway). By the time quassel-0.7 is released, even more time will have gone by (and the next stable Qt release should be out).

The core's dep will remain at Qt 4.4.0 for now, so people running Debian Stable on their server should be ok. The deps for the current stable release 0.6.x won't be changed, so subsequent 0.6.x releases will still be fine with Qt 4.4 for the core and Qt 4.5 for the client.

Bumping cmake requirement

Following KDE's example, Quassel's master branch (what will become 0.7.x) will require CMake >= 2.6.4 for building starting in May (about two weeks from now). The reason for this is that our KDE integration obviously uses parts of KDE's build system, and we'd like to avoid spurious bugs by something not working as expected in some random script included somewhere, just because your CMake is too old.

CMake 2.6.4 has been out for a long time (we've been at 2.8.x for ages!) and should be included in most, if not all, distros. If it isn't, you can just usea recent binary release for cmake, untar it somewhere, and use that instead of the system installed one.

Quassel 0.6.x will continue to work fine with cmake-2.6.2; this change will only affect the development branch.

Syndicate content